Degraded performance with GoFormz Template Events
Incident Report for GoFormz
Resolved
This incident has been resolved.
Posted Oct 25, 2019 - 16:22 PDT
Investigating
Service monitoring has revealed degraded performance of the Template Events functionality which may impact the on-time execution of customers' Template Events. GoFormz engineering is currently troubleshooting this issue and will update this status as more information is available.
Posted Oct 25, 2019 - 15:42 PDT
This incident affected: Web App.