Service Interruption: Email Delivery
Incident Report for GoFormz
Resolved
This incident has been resolved.
Posted Aug 02, 2023 - 10:10 PDT
Monitoring
This interruption has been resolved and all email delivery is operational. We are continuing to monitor the service closely.
Posted Aug 01, 2023 - 07:29 PDT
Investigating
We are investigating an interruption to the email delivery service leveraged by GoFormz. This includes system emails such as reset password requests and user invites, as well as, automated emails triggered through Workflow and/or Template Events.
Posted Jul 31, 2023 - 07:10 PDT
This incident affected: Email Delivery.