Checkbox values may show the incorrect value after form completion (mobile app version 4.0.1391 only)

Incident Report for GoFormz

Postmortem

Postmortem: Mobile checkbox display issue (August 21–25, 2025)

Resolved: August 25, 2025 at 12:22 PM PT
Impact window: August 21–25, 2025
Affected platforms: Android, iOS and Windows mobile apps (version 4.0.1391)

Issue summary:
Between August 21 and August 25, a bug in GoFormz mobile app version 4.0.1391 caused checkbox and checkbox group values to sometimes display incorrectly. The issue was limited to mobile forms using these field types and did not affect all forms and completions.

Root cause:
A recent mobile release introduced a logic error that affected how checkbox states were saved during certain form interactions. This led to a mismatch between user input and the final stored values.

Resolution:
The issue was resolved with mobile app version 4.0.1395, released to all app stores on August 25. Users must update to this version to prevent further occurrences.

Next steps for customers:
We recommend reviewing forms submitted between August 21 and August 25 using the mobile app version 4.0.1391, especially if they include checkbox fields. Not all forms in this timeframe are confirmed to be impacted, but reviewing them will help ensure data accuracy.

Preventive actions:
We are implementing additional automated testing for field-specific behavior in mobile forms and improving release QA processes for core field logic.

We appreciate the customers who flagged this issue quickly and thank you for your patience while we worked toward a resolution.

Posted Aug 26, 2025 - 09:20 PDT

Resolved

This incident has been resolved. We will share a post-mortem shortly.
Posted Aug 26, 2025 - 08:52 PDT

Monitoring

A fix has been implemented and released to the mobile app stores (Android and iOS). Please update to the latest mobile app version: 4.0.1395.

Users must update to this mobile app version to resolve the issue on their device. We are continuing to monitor, and we will share a post-mortem shortly.
Posted Aug 25, 2025 - 12:51 PDT

Identified

We’ve identified a bug affecting checkbox fields on forms in the mobile app. Following last week’s app update (August 21 for Android, August 22 for iOS), checkbox and checkbox group values may show the incorrect value after form completion.

This affects all users who are using the mobile app version 4.0.1391 and have completed forms with checkboxes since their respective app releases last week. We are actively working on a fix and will provide an update as soon as a resolution is available.
Posted Aug 25, 2025 - 08:50 PDT
This incident affected: Mobile Apps (iOS App, Andoird App, Windows App).