Continued interrupted performance when sending Public Forms via text message
Incident Report for GoFormz
Postmortem

Overview

GoFormz’s SMS/Text delivery option for Public Form links experienced instability due to misuse by fraudulent accounts. As a result, the text service supporting this function was temporarily suspended.

Timeframe of Impact

Intermittent outages between 5/30/23 8pm PT to 6/2/23 9am PT

Who was this impacted?

  1. Users who created a Public Form link based on an existing Form and sent it using the “Text” option manually from the Public Forms Modal during the timeframe above
  2. Workflows that created a Public Form link based on an existing form and sent it using the “Text” option in the Workflow step during the timeframe above

Resolution

The GoFormz team took and is continuing to take several mitigating actions to return to operational service and ensure this does not occur again including:

  1. Locked all activity from the offending accounts
  2. Adjusted the rate limit set for how many public forms can be sent in a given time period
  3. Added URL detection to the body of public form messages that finds and prevents any links from being sent (with the exception of the Public Form Link to the GoFormz Form)

Current Status

The Workflow Create Public Form Step has been returned to full operational status.

Sending a Public Form as a text message will remain unavailable when using the Create Public Form modal in the web application as we continue to take additional measures that prevent similar abuse. We expect this functionality to be returned in the near future.

Posted Jun 07, 2023 - 10:21 PDT

Resolved
This incident has been resolved. GoFormz is continuing to monitor this function closely.
Posted Jun 02, 2023 - 19:37 PDT
Monitoring
A fix has been implemented for our Workflow solution and we are continuing to monitor the create public form on the Web App pathway closely before resolving.
Posted Jun 02, 2023 - 08:18 PDT
Investigating
GoFormz is investigating an issue that is preventing Public Form links sent using the Text option to not be delivered as expected.

Note: this impacts Public Forms that are sent using the Text option in the Create Public Form modal and the Create Public Forms Workflow step.

As an alternative, please send Public Forms using the Email option until resolved. Updates will be provided here shortly.
Posted Jun 01, 2023 - 08:11 PDT
Monitoring
Sending a Public Form via text message has been restored to Operational status for both the Workflow and Web App components of this feature. We are continuing to monitor this function closely and will share a postmortem shortly.
Posted May 31, 2023 - 18:34 PDT
Investigating
GoFormz is investigating an issue that is preventing Public Form links sent using the Text option to not be delivered as expected.

Note: this impacts Public Forms that are sent using the Text option in the Create Public Form modal and the Create Public Forms Workflow step.

As an alternative, please send Public Forms using the Email option until resolved. Updates will be provided here shortly.
Posted May 31, 2023 - 08:30 PDT
This incident affected: Web App and Automated Workflows.