GoFormz iOS app version 4.0.777 is experiencing a partial outage when opening app (only impacting devices using iOS 18)
Incident Report for GoFormz
Postmortem

On Oct 4, 2024, an issue was identified affecting users’ ability to log in when using an iOS 18+ device. This issue did not impact users already logged into the GoFormz app or using an iOS version before iOS 18.

The root cause of this issue was a workaround implemented yesterday (10/3/24) in the GoFormz mobile app version 4.0.777 to accommodate compatibility with iOS 18 beta versions.

However, Apple also recently updated iOS 18+ devices to address the workaround’s original need, causing the fix applied for the beta versions to exhibit unexpected behavior and prevent users from logging in.

To resolve this issue, GoFormz released a new iOS mobile app version (v.4.0.789) that removes this code and operates as expected.

The GoFormz team is focusing on implementing adjustments to our internal mobile release testing processes to prevent incidents like this from occurring again.

Posted Oct 04, 2024 - 12:27 PDT

Resolved
This issue has been resolved, and a new iOS GoFormz app version is available to download from the App Store. If you are using a device running iOS 18 or higher, please update your GoFormz app to version 4.0.789 as soon as possible.

A postmortem of this incident will be shared shortly.
Posted Oct 04, 2024 - 10:53 PDT
Identified
We have identified the source of the issue and are working to release a fixed iOS mobile app version.
Posted Oct 04, 2024 - 08:47 PDT
Investigating
GoFormz iOS app version 4.0.777 is experiencing a partial outage when opened using an iOS 18-enabled device. We are working to release a new iOS app version as soon as possible, removing the root cause of this occurrence.
Posted Oct 04, 2024 - 07:27 PDT
This incident affected: Mobile Apps (iOS App).