Interrupted email delivery performance (Workflow and Template Events)

Incident Report for GoFormz

Postmortem

Postmortem: Email Delivery Interruption

Incident Duration:

  • Start: Tuesday, September 16, 2025 at approximately 7:50 AM PT
  • End: Tuesday, September 16, 2025 at approximately 5:00 PM PT

Impact:

During this incident, Email Delivery via Workflow, Template events, and Account Management (reset password/invite user emails) were unavailable for all GoFormz accounts.

Root Cause:

Our email provider temporarily suspended outbound traffic from GoFormz due to suspicious activity.

  • Important: At no point was customer data exposed or put at risk. The suspicious activity was isolated to those specific accounts.

Resolution:

GoFormz worked closely with our provider to validate the issue, secure our systems, and restore normal service.

How this impacts you:

Most emails triggered to be sent during this time period were ultimately delivered after resolution.

However, some were not delivered. For those impacted emails, please follow the below remediation instructions:

  • Template Events: Re-trigger manually (e.g., by opening/completing the form again).
  • Workflow Jobs: Select the “...” actions button to the right of the job and click “Rerun.”

    • Customers can rerun these jobs one by one.
    • If you have a significant number of jobs to rerun, please reach out to our support team at support@goformz.com and we can help you bulk rerun batches.
  • Password Reset Emails: Resend password reset requests. Customers can resend in bulk from the Users & Groups page.

Preventive Measures:

We have strengthened safeguards with our email provider and are improving monitoring to reduce the likelihood of similar interruptions in the future.

Posted Sep 17, 2025 - 10:13 PDT

Resolved

The issue affecting Email Delivery via Workflow and Template events caused by a SendGrid interruption has been fully resolved. Email delivery is now functioning normally across all accounts. We will continue to monitor, but no further impact is expected.
Posted Sep 16, 2025 - 17:03 PDT

Update

We are continuing to work with SendGrid to resolve the issue affecting Email Delivery via Workflow and Template events. The problem is still impacting all accounts. We will provide the next update as soon as more information is available.
Posted Sep 16, 2025 - 13:29 PDT

Identified

We are currently experiencing issues with Email Delivery via Workflow and Template events due to an interruption with our email provider, SendGrid. This is impacting all accounts. Our team is actively working with SendGrid to restore services as quickly as possible. We will provide updates as soon as more information becomes available.
Posted Sep 16, 2025 - 08:16 PDT
This incident affected: Email Delivery.