Intermittent Login Issues

Incident Report for GoFormz

Postmortem

At approximately 7:20 am PT on Monday, March 3rd, it was identified that some GoFormz users were experiencing errors when logging into the platform. The GoFormz Engineering team quickly investigated and found that Microsoft Azure released an update that impacted our CDN layer.

At approximately 11:10 am PT on Monday, March 3rd, the GoFormz Engineering team implemented a fix and restored all users’ ability to access the GoFormz platform as expected.

This issue is now resolved, as we have continued to see stable performance throughout the day. If you have any further questions, please contact your account manager or email support@goformz.com.

Posted Mar 03, 2025 - 15:12 PST

Resolved

This issue is now resolved, as we have continued to see stable performance throughout the day. If you have any further questions, please contact your account manager or email support@goformz.com.
Posted Mar 03, 2025 - 14:47 PST

Monitoring

The root cause of this issue has been identified, and a fix has been implemented. All services are operating as expected. We are continuing to monitor performance.
Posted Mar 03, 2025 - 11:09 PST

Investigating

Some accounts may be experiencing intermittent issues when attempting to log in to the GoFormz platform. We are investigating the cause of these errors and will share an update shortly.
Posted Mar 03, 2025 - 07:59 PST
This incident affected: Web App and Mobile Apps (iOS App, Andoird App, Windows App).