Degraded Performance with GoFormz Forms and Template services
Incident Report for GoFormz
Postmortem

After review and consultation with Microsoft Azure support, it was determined that an Azure platform event, occurring shortly before GoFormz experienced degraded performance, triggered an application recycle leading to instability with our Forms, Template, and Auth services.

Azure support has provided GoFormz engineering and ops teams with specific mitigation steps to more quickly resolve any impact to our services if a future similar platform event occurs.

Posted Jan 10, 2020 - 15:45 PST

Resolved
This incident has been resolved.
Posted Jan 10, 2020 - 10:09 PST
Monitoring
After troubleshooting with Azure Support, Forms and Template services have returned to normal operation. We will continue to work with Azure Support to determine the root cause and update this issue upon such findings.
Posted Jan 09, 2020 - 16:54 PST
Investigating
We are currently investigating an issue that is impacting Forms and Template pages. Our engineers are working with Azure support to determine the root cause.
Posted Jan 09, 2020 - 16:24 PST
This incident affected: Web App and Automated Workflows.